BC 1.x und PHP 7.3

Support zu BlackCat CMS allgemein
Antworten
Benutzeravatar
shadowcat
Administrator
Beiträge: 4054
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

BC 1.x und PHP 7.3

Beitrag von shadowcat » Mo 12. Aug 2019, 09:20

Es gibt ein paar kleinere Anpassungen, die notwendig sind, damit BC 1.3.x problemlos mit PHP 7.3 läuft. Im Wesentlichen betrifft das eine "deprecated"-Meldung bezüglich der Funktion each(), die unter anderem von Dwoo noch verwendet wird. Je nach Einstellung der PHP-Fehlerberichte bekommt Ihr die gar nicht zu sehen.

Ich bereite eine Release-Version vor, die das behebt, wer aber bisher keine Probleme hatte, muss das Update auch nicht unbedingt einspielen.
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

Antworten