Gruppenberechtigung - Teilweise kein Zugriff

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: Gruppenberechtigung - Teilweise kein Zugriff

Beitrag von shadowcat » Mo 1. Apr 2019, 13:55

Also hier ist der Commit dazu:
https://github.com/BlackCatDevelopment/ ... dd1067c8ee

Sollte in v1.3.3 enthalten sein.
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

nicoletta
Beiträge: 139
Registriert: Mi 29. Okt 2014, 17:55
Wohnort: Oldenburg

Re: Gruppenberechtigung - Teilweise kein Zugriff

Beitrag von nicoletta » Mo 1. Apr 2019, 18:49

Version 1.3

immer noch das Problem das User nicht auf Medien zugreifen können, bzw. upload können.
Das Problem mit cat_galerie besteht auch weiterhin. Ich habe unterschiedliche PHP Versionen probiert.

Meinst Du ich kann gefahrlos ein Update durchführen. Das muss ich noch manuell machen, oder?

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: Gruppenberechtigung - Teilweise kein Zugriff

Beitrag von shadowcat » Di 2. Apr 2019, 14:29

Es gibt ein Update-Script, was meinst Du mit manuell? Vorher alles sichern, insbesondere pages-Verzeichnis und Datenbank, dann sollte das eigentlich klappen.

Bei der Gallery kann ich leider nicht helfen.
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

Benutzeravatar
creativecat
Beiträge: 1067
Registriert: Mi 6. Feb 2013, 12:41
Kontaktdaten:

Re: Gruppenberechtigung - Teilweise kein Zugriff

Beitrag von creativecat » Di 2. Apr 2019, 15:05

nicoletta hat geschrieben:
Mo 1. Apr 2019, 18:49
Das Problem mit cat_galerie besteht auch weiterhin. Ich habe unterschiedliche PHP Versionen probiert.
Hilft mir mal bitte auf die Sprünge. Ich hatte das als erledigt im Kopf gespeichert :oops:

nicoletta
Beiträge: 139
Registriert: Mi 29. Okt 2014, 17:55
Wohnort: Oldenburg

Re: Gruppenberechtigung - Teilweise kein Zugriff

Beitrag von nicoletta » Di 2. Apr 2019, 21:26

ok, es gibt ein Update Script. Da muss ich mal schauen. Vorher Sicherung ist klar.

Zur Cat_Galerie: manchmal funktioniert ein Upload, dann wieder nicht. Momentan bekomme nicht mal ich einen Upload hin.

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: Gruppenberechtigung - Teilweise kein Zugriff

Beitrag von shadowcat » Mi 3. Apr 2019, 10:07

My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

nicoletta
Beiträge: 139
Registriert: Mi 29. Okt 2014, 17:55
Wohnort: Oldenburg

Re: Gruppenberechtigung - Teilweise kein Zugriff

Beitrag von nicoletta » Mi 3. Apr 2019, 10:21

Vielen Dank.

Eine Bitte. Es wäre schön wenn Links im Forum in einen neuen TAB geöffnet werden und nicht im Gleichen.

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: Gruppenberechtigung - Teilweise kein Zugriff

Beitrag von shadowcat » Mi 3. Apr 2019, 15:54

Ich weiß nicht ob man das einstellen kann...
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: Gruppenberechtigung - Teilweise kein Zugriff

Beitrag von shadowcat » Mi 3. Apr 2019, 15:57

Hm, dafür muss man an Core-Dateien rumpfuschen, das geht beim Update dann wieder verloren. :/
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

nicoletta
Beiträge: 139
Registriert: Mi 29. Okt 2014, 17:55
Wohnort: Oldenburg

Re: Gruppenberechtigung - Teilweise kein Zugriff

Beitrag von nicoletta » Mi 3. Apr 2019, 22:27

Ich habe Admina-Rechte zu einem phpBB Board Version 3.2.5.
Dort war es schon immer so das Links in einem neuen Tab geöffnet werden. Es ist das gleiche Standard Template aber ich finde auch keine Einstellung dazu.

Aber das ist wohl eher eine andere Baustelle.

Antworten