Installationsanleitung

nicoletta
Beiträge: 139
Registriert: Mi 29. Okt 2014, 17:55
Wohnort: Oldenburg

Installationsanleitung

Beitrag von nicoletta » Mi 4. Jan 2017, 02:35

Hallo,

Ich wollte jemanden BlackCat CMS nahelegen und dieses neu installieren. Dabei stellte ich fest das nirgends eine Installationsanleitung zu finden ist.
Im Handbuch werden die Voraussetzungen aufgelistet, aber dann geht es mit der Installation weiter nachdem alle Dateien auf dem Webserver installiert sind. Allerdings wird der Pfad für den Aufruf nicht genannt und auch nicht evt. Rechteänderungen von Ordnern und Dateien.

Also wer BC völlig neu mal installieren möchte ist recht aufgeschmissen.

Ich schlage eine .txt. im Downloard-Paket vor für eine Schnellanleitung und Verweis auf eine ausführliche Anleitung.

Ich erinnere mich daran das es da mal eine Wicki gab zu BC. Wo ist die denn hin?

Benutzeravatar
Morpheus
Beiträge: 991
Registriert: Do 8. Aug 2013, 10:49
Kontaktdaten:

Re: Installationsanleitung

Beitrag von Morpheus » Mi 4. Jan 2017, 09:26

Keiner ist unnütz, er kann immer noch als schlechtes Beispiel dienen!

nicoletta
Beiträge: 139
Registriert: Mi 29. Okt 2014, 17:55
Wohnort: Oldenburg

Re: Installationsanleitung

Beitrag von nicoletta » Mi 4. Jan 2017, 10:22

Ich danke Dir @Morpheus.

Dann will ich mich doch mal wieder etwas mehr mit BC beschäftigen ;)

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: Installationsanleitung

Beitrag von shadowcat » Mi 4. Jan 2017, 10:23

Es gibt eine solche Datei, allerdings nur, wenn man BC bei GitHub runterlädt. Aber guter Hinweis, ich überleg mal, wie ich das am besten einbaue.

https://github.com/BlackCatDevelopment/ ... .2/INSTALL
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: Installationsanleitung

Beitrag von shadowcat » Mi 4. Jan 2017, 10:24

nicoletta hat geschrieben:Dann will ich mich doch mal wieder etwas mehr mit BC beschäftigen ;)
Guter Vorsatz! :mrgreen: Bitte weiterhin alle Fragen und Anregungen posten!
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

nicoletta
Beiträge: 139
Registriert: Mi 29. Okt 2014, 17:55
Wohnort: Oldenburg

Re: Installationsanleitung

Beitrag von nicoletta » Mi 4. Jan 2017, 13:27

Gibt es noch Probleme mit PHP 7. Ich bekomme beim Aufruf von ~/install/index.php nur eine weisse Seite.

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: Installationsanleitung

Beitrag von shadowcat » Mi 4. Jan 2017, 14:43

Welche Version?
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: Installationsanleitung

Beitrag von shadowcat » Mi 4. Jan 2017, 14:47

Hab's mal schnell in meiner v2.0 Umgebung getestet, da ist PHP7 installiert, funktioniert. (v1.2.2) Wobei ich das jetzt nicht installiert habe, nur den Installer aufgerufen.
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

nicoletta
Beiträge: 139
Registriert: Mi 29. Okt 2014, 17:55
Wohnort: Oldenburg

Re: Installationsanleitung

Beitrag von nicoletta » Mi 4. Jan 2017, 15:03

Ich habe ein LAMP Ubuntu 16.04.3 aufgesetzt mit PHP 7.0.8.
BC 1.2.2 von Github heruntergeladen.

Auf einem XAMPP lief die Installation mit PHP 5.x an, aber fand die Datenbank nicht.

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: Installationsanleitung

Beitrag von shadowcat » Mi 4. Jan 2017, 16:00

Hm. Ich hab hier ein 7.0.4. Das einzige Problem ist, daß meine Umgebung (Portable auf Basis von USBWebserver) kein http akzeptiert (nur https), was beim Installer dazu führt, daß die ganzen Ressourcen (CSS und so) nicht geladen werden können. Das erklärt aber nicht die weiße Seite. Guck doch bitte mal im error.log des Webservers, ob da was zu finden ist.
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

Antworten