Umlautproblem mit flexContent

offizieller Support zum kitFramework und seinen Erweiterungen; auch zu allen früheren Addons wie KeepInTouch (KIT1) etc.
Antworten
Benutzeravatar
shadowcat
Administrator
Beiträge: 3952
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Umlautproblem mit flexContent

Beitrag von shadowcat » Fr 19. Jun 2015, 14:46

Ich stelle gerade ein Problem mit Umlauten in flexContent fest, das ich bis in das darunterliegende Symfony Framework verfolgt habe. Möglicherweise hängt es mit der PHP-Version zusammen, das kann ich aber nicht mit Sicherheit sagen. Falls noch jemand ähnliche Probleme feststellt, bitte melden.

Added in 2 hours 4 minutes 18 seconds:
Ein Workaround: Man kann den CKEditor so konfigurieren, daß er Sonderzeichen in HTML-Entities umwandelt. Aus "ü" wird dann z.B. "ü". Das ist nicht gerade elegant, kann aber akute Probleme zumindest zeitweise lösen. Nachteil: Man muß alle flexContent-Beiträge einmal im Backend öffnen und neu speichern.

Um die Konfiguration zu aktivieren, die Datei

/kit2/extension/phpmanufaktur/phpManufaktur/flexContent/Template/default/admin/ckeditor.config.content.js

öffnen. Dort gibt es eine Zeile

config.entities = false;

Diese ändern in

config.entities = true;

Das gleiche ggfs. in den anderen ckeditor.*.js Dateien wiederholen.

Diese Anpassung bitte nur bei akuten Problemen mit Umlauten vornehmen!
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

Antworten