BC 1.2.1 Installation bricht ab Step 3 ab

Support zu BlackCat CMS allgemein
Antworten
nicoletta
Beiträge: 139
Registriert: Mi 29. Okt 2014, 17:55
Wohnort: Oldenburg

BC 1.2.1 Installation bricht ab Step 3 ab

Beitrag von nicoletta » Fr 16. Sep 2016, 17:03

Dieses schickte mir ein Freund den ich für BlackCat begeistern möchte:

Server-Adresse: 127.0.0.1
Port: 3306 (Standardport)
Datenbankname: <Gruppenprefix>_<Name>
Benutzername und Passwort werden über die Benutzerverwaltung eingerichtet.

Der MySQL-Server nimmt Verbindungen nur an wenn diese von derselben Maschine kommen, andere Verbindungen werden durch die Firewall geblocked sofern diese keinen authentifizierten Ursprung haben. Außerdem werden UNIX-Domain-Sockets nicht unterstützt, sodass man als Server-Adresse die IP-Adresse 127.0.0.1 anstatt des Hostnamens localhost angeben muss.

Step 3:

Mit der 127.0.0.1 kam es bei der Installation zu dem Fehler das der Name der Datenbank wohl nicht erkannt wurde!

Daraufhin wurde mir mysql.localhost als Ersatz für die 127.0.0.1 eingerichtet!

Nun geht die Installation bis Step 6: und zeigt mir nun folgenden Fehler an!

Check tables
password


Das Password für die Datenbank ist aber richtig eingegeben, da ich es mit Copy and Paste gemacht habe!

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: BC 1.2.1 Installation bricht ab Step 3 ab

Beitrag von shadowcat » So 18. Sep 2016, 12:22

Bei der localhost-Sache hab ich irgendwie so'n Klingeln im Hinterkopf... irgendwas war da bei WBCE... muß ich nochmal kramen...

Im temp-Verzeichnis gibt es eine inst.log, da steht evtl. etwas mehr drin.
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: BC 1.2.1 Installation bricht ab Step 3 ab

Beitrag von shadowcat » So 18. Sep 2016, 12:27

Die Fehlermeldung bezieht sich nicht auf das Datenbank-Kennwort, sondern auf das Kennwort des Admin-Benutzers. Bitte mal in Tabelle <Präfix>users nachschauen, ob dort ein Eintrag vorhanden und das Kennwort-Feld gefüllt ist.
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: BC 1.2.1 Installation bricht ab Step 3 ab

Beitrag von shadowcat » Di 11. Okt 2016, 10:43

Ich versuche gerade, BC 1.2.2 (noch nicht erschienen!) bei AllInkl zu installieren und habe genau das gleiche Problem. Mal schauen, ob ich was rausfinde.
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: BC 1.2.1 Installation bricht ab Step 3 ab

Beitrag von shadowcat » Di 11. Okt 2016, 10:48

Zwischenstand: Das Login im Backend funktioniert, es wurden allerdings die Standardseiten nicht angelegt.

Das Anlegen einer neuen Seite funktioniert.

Ich habe eine Vermutung, woran es liegt, muss das aber nochmal genauer unter die Lupe nehmen. Ansonsten: Wenn das Fehlen der Standardseiten akzeptabel ist, den Fehler einfach ignorieren und im BE anmelden.
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: BC 1.2.1 Installation bricht ab Step 3 ab

Beitrag von shadowcat » Di 11. Okt 2016, 10:53

My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

Benutzeravatar
shadowcat
Administrator
Beiträge: 4570
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: BC 1.2.1 Installation bricht ab Step 3 ab

Beitrag von shadowcat » Do 13. Okt 2016, 16:50

Leider kann ich den Fehler in meiner lokalen Umgebung nicht reproduzieren. Wer auch das Problem hat und sich traut kann aber mal die angehängte index.php ausprobieren.

VOR der Installation in das Verzeichnis <CAT_PATH>/install entpacken bzw. die dortige index.php durch die im ZIP ersetzen.
Dateianhänge
index.zip
(16.82 KiB) 100-mal heruntergeladen
My software never has bugs, it just develops random features.
BC1: PHP 5.5.11 (cli), mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9
BC2: PHP 7.2.7, mariaDB 10.2.13, no Apache

Antworten