Security Problem mit jQuery Plugin cattranslate

Hier werden veraltete News archiviert
Benutzeravatar
shadowcat
Administrator
Beiträge: 2356
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Security Problem mit jQuery Plugin cattranslate

Beitragvon shadowcat » Mi 13. Aug 2014, 13:41

Gerade erreichte uns ein Report des High-Tech Bridge Security Research Lab bezüglich eines Problems mit unserem jQuery Plugin cattranslate. Dieses stellt eine Javascript-Schnittstelle zu unseren Sprachdateien und unserem entsprechenden Helper zur Verfügung. Kurz gesagt, Javascripts können hiermit Übersetzungen aus den Sprachdateien holen.

https://www.htbridge.com/advisory/HTB23228

Wir fixen das natürlich so bald wie möglich!
My software never has bugs, it just develops random features.
Entwicklungsumgebung: PHP 5.5.11 (cli) with Xdebug v2.2.5, mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9

Benutzeravatar
shadowcat
Administrator
Beiträge: 2356
Registriert: Di 5. Feb 2013, 10:36
Kontaktdaten:

Re: Security Problem mit jQuery Plugin cattranslate

Beitragvon shadowcat » Mi 13. Aug 2014, 14:11

Hier ein schneller Fix. Die enthaltene Datei cattranslate.php nach <Pfad>/modules/lib_jquery/plugins/cattranslate kopieren.
Dateianhänge
cattranslate.zip
(742 Bytes) 90-mal heruntergeladen
My software never has bugs, it just develops random features.
Entwicklungsumgebung: PHP 5.5.11 (cli) with Xdebug v2.2.5, mySQL 5.6.16 with 'strict' enabled, Apache 2.4.9


Zurück zu „Archiv“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste